Network Toolkit – Migrating from Trunk to Etherchannel

I recently had to move from a single trunk link between a 6509 and a 3750 to an etherchannel configuration. I ran through the process using a pair of 3560’s but still ran into a few surprises. Thought I would share what I had found to save you some problems when you have to do this. I will show both ends of the configuration. As I go through this process, one thing that I learned was to start the process at the remote end in case there was a problem so I most likely wouldn’t cause a problem on the 6509 end which happened to be a core switch for the network in question. As a general rule, I first shut the individual interfaces before connecting the fiber/copper connections that were to be a part of the final etherchannel configuration. I normally prefer to use the same port-channel number at each end of the connection to help in the troubleshooting process. In this case that wasn’t possible. Ran into a limitation I hadn’t seen before where the maximum number that the 3750 would allow for a port-channel interface as 48. For that reason, I used a different number at the 3750 end of the configuration. Due to other port-channels present on the 6509, I left the port channel configuration number at its original number.

! 6509 end of the configuration
!
! You need to setup the port channel with the appropriate configuration before
! going to the interface(s) that will be a part of the etherchannel
!
interface port-channel 100
desc Etherchannel link to 3750
no shut
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 254
!
! example interface configuration
! new interface to be added to port channel group
!
interface gi1/3
desc Etherchannel link to 3750
shut
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 100 mode on

! 3750 end of the configuration
!
interface port-channel 48
desc Etherchannel link to 6509
no shut
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 254

int gi1/0/49
desc Etherchannel link to 6509
shut
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 254
channel-group 48 mode on

The next step will be to convert the existing trunk connection over to etherchannel to minimize the disruption to the network.

! 3750 configuration
! Current trunk interface
int gi1/0/48
channel-group 48 mode on

At this point in the process, you will probably loose the connection to the 3750. If you check the interface on the 6509, you should probably find it in an err-disabled state. Go ahead and put the trunk interface on the 6509 into the etherchannel group. Next, you will need to shut and then no shut the interface. Give the interface a few seconds and then the etherchannel configuration should come online.

! 6509 end of the configuration
! Current trunk interface
!
int gi1/25
channel-group 100 mode on

Once the interface comes up, you can issue the commands listed next to verify that the etherchannel is up. As you run the commands, there will be a legend displayed that will explain all the indicators you will see and be able to tell that the etherchannel is now up.

! Commands for the 6509 end
!
sh etherchannel 100 summary
sh etherchannel 100 port-channel

! Commands for the 3750 end
!
sh etherchannel 48 summary
sh etherchannel 48 port-channel

Now that you have the original trunk connect up as a part of the etherchannel config, you can add additional interfaces (up to a total of 8 without any disruptions to the network. Once you have an additional interface(s) assigned to the etherchannel configuration, you can shut down the original interface you first brought the etherchannel configuration if that was, for example, a copper connection and you are moving to an all fiber connection setup. Once you have shut the interfaces in question, you an remove the channel-group command and that removes that interface from the group. I would suggest anytime you add or subtract any interfaces to a port channel group that you run the sh etherchannel commands at each end of the connection to make sure that everything is ok.

Send to Kindle
This entry was posted in Blog Entries, CCNP and tagged , . Bookmark the permalink.