Network Toolkit – Basic etherchannel setup for server use

Once in a while I need to setup a multi-port connection between a server and one of the Cisco switches. This process is usually started by the vendor whose product is running on a server or by a group who is consistently either filling up the 1 Gigabit network port or wants to have a second network card connected to the same switch so that if a port or the network card has a problem, that the traffic will continue, even at a reduced amount of bandwidth. When I have done this in the past, I have found the vendor doesnt know what type of etherchannel configuration is needed for their setup. What I have found is that I have to use mode on for the connection to come up to where it is useable. When I did this the last time, you are limited to combining up to 8 individual ports into one bundle. Check the hardware that you are using and the version of IOS as it is possible that the limit might eventually be increased. To increase redundancy, I usually spread the ports in an etherchannel between ASIC’s on a single switch/switch blade at a minimum. If I am using a 6500 chassis or 3750 style stack, I try to extend that spreading the etherchannel across multiple blades/stack switch members.

conf t
!
! set ports to default settings before beginning etherchannel setup
! channel-group mode on = server/workstation doesnt use/support negotiation protocols
!
default interface gi2/16
default interface gi3/15
!
int gi2/16
switchport
switchport mode access
switchport access vlan 90
spanning-tree portfast
channel-group 102 mode on
!
! After the first use of the channel-group command, you see see a message that the port channel has been created.
!
int gi3/15
switchport
switchport mode access
switchport access vlan 90
spanning-tree portfast
channel-group 100 mode on
!
! You will to pick a number between from 1 to 256 to identify this particular port channel config on this specific switch.
!
int po102
switchport
no shut
exit
!
! To bring the port channel up, you will need to do a no shut in order for it to come to life
!

Now that you have created the port channel, plug in the network cards to the ports you have configured. Next we will do do some verification that everything is working.

sh etherchannel 102 summary
! Replace the 102 with the number of the port channel that was configured

Each port listed should show as a P for in port-channel

switch#sh etherchannel 101 summary
Flags: D – down P – bundled in port-channel
I – stand-alone s – suspended
H – Hot-standby (LACP only)
R – Layer3 S – Layer2
U – in use N – not in use, no aggregation
f – failed to allocate aggregator
M – not in use, no aggregation due to minimum links not met
m – not in use, port not aggregated due to minimum links not met
u – unsuitable for bundling
d – default port
w – waiting to be aggregated
Number of channel-groups in use: 2
Number of aggregators: 2
Group Port-channel Protocol Ports
——+————-+———–+———————————————–
101 Po101(SU) – Gi2/4(P) Gi3/2(P)

Send to Kindle
This entry was posted in Blog Entries and tagged . Bookmark the permalink.